X
تبلیغات
رایتل
آموزش نصب و کار با سیستم عامل جنتو Gentoo OS

قربانی نمودن پایداری بخاطر بروز بودن

دوشنبه 22 آبان‌ماه سال 1391 ساعت 01:32 ب.ظ

این یک انتخاب شخصی برای هر کسی است که آیا مایل است از گنولینوکس خودش به عنوان سیستم عامل پایدار استفاده نماید یا به عنوان سیستم عامل بروز.
شخصا به دوستانی بروز بودن برایشان از پایداری مهمتر است پیشنهاد می کنم بسراغ سیستم عامل هائی مانند اوبونتو بروند که اصولا فلسفه وجودی آنها بروز بودن است و شتاب بروز رسانی آنها هر کاربری را کلافه می کند اما به هر حال جنتو همه اش درباره انتخاب هاست. می توانید نسخه های جدید نرم افزارها را هم بروی سیستم خود نصب نمایید.

ایبویلد های موجود بروی پرتیج شامل آخرین نسخه های نرم افزارها به دو صورت است: آخرین نسخه های پایدار stable و آخرین نسخه ناپایدار Unstable که در جلوی این نرم افزارها کلمه Mask را مشاهده می نمایید. این به آن معنی است که گسترش دهندگان از پایداری این نسخه بروی کامپیوتر شما مطمئن نیستند. البته پشتیبانی رسمی هم در ایراداتی که با استفاده از آنها ممکن است برای سیستم شما بوجود بیاید، صورت نمی گیرد (هرچند تقریبا همه می دانند که ایرادات هم معمولا بسیار اندک هستند ;) ).
اما به هر حال همیشه به تازه کارها با سیستم های گنولینوکس پیشنهاد می شود که در ابتدا جانب پایداری سیستم عاملشان را بگیرند. اما به هر حال بخاطر داشته باشید که Mask بودن یک نسخه از یک نرم افزار به معنی آن است که گسترش دهندگان بازخورد کارکرد سیستم شما بعد از نصب این نرم افزار و ایرادات امنیتی ممکن را بررسی ننموده اند.
برای اینکه آخرین نسخه پایدار یک بسته را ببینید، از دستور زیر استفاده نمایید:


emerge -p package


و برای اینکه آخرین نسخه Mask را مشاهده نمایید:


ACCEPT_KEYWORDS="~x86" emerge -p package


که البته حتما می دانید که آن x86 هم به معماری سیستم اشاره دارد.

برای نصب یک بسته mask ابتدا بسراغ اعلام نمودن آن به Gentoo می رویم. برای اینکار فایلی در آدرس زیر قرار داده شده است:


/etc/portage/package.keywords


اگر نیست، آنرا بوجود بیاورید. آنچه در آن می نویسیم، اعلام بسته ائی است که می خواهیم آخرین نسخه Mask آنرا استفاده نماییم. مثلا برای نصب فایرفاکس با استفاده از دستور اکو بصورت زیر اعلام می کنم:


echo net-www/mozilla-firefox ~x86 >> /etc/portage/package.keywords


اکنون بسته را با استفاده از دستور زیر نصب می کنم:


ACCEPT_KEYWORDS="~x86" emerge  mozilla-firefox


و به تماشای دانلود شدن، کامپایل شدن و نصب شدن آن می نشینم.

بخاطر داشته باشید که همه چیز درباره انتخاب هاست. ممکن است شما بخواهید آخرین نسخه Hard Masked بسته را استفاده نمایید. این دیگر ممکن است بطور جدی سیستم شما را بشکند :)